Saitek Instrument Panel

OTG Blog Forums Software Saitek Instrument Panel

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3427
    Profile photo of Christian
    Christian
    • Posts: 3

    We have 8 Saitek panel screens. They are used as a standard 6 pack plus two for other purposes. I have installed the plugin from Saitek, I believe it re directs to Logitech’s website but I cannot get the instrument panels to turn on.

    On a side note, I installed the test software for the com panel, switch panel and multi panel. The test software recognizes my instruments. I have windows talking to my instruments but I am still missing software for my instrument panel screens.

    When I power the computer up the screens will have a faint led backlight and then after about 10 seconds they go to sleep. I believe this is due to not having the software, or its a power issue. I am using 2 usb 2.0 insignia hubs and the amperage is 4amps. It should have enough power to turn all of the instruments on. Can I use any of the instruments with usb 3.0 ports? The pro flight yoke seems to run in the 3.0 slot but the panels don’t like to be ran in a 3.0 port. Windows has a hard time recognizing them.

     

    I am really in need of help, we have a whole flight sim built but cannot get the instruments to run.

    0
    #3431
    Profile photo of Basement Fly Guy
    Basement Fly Guy
    • Posts: 218

    2 amps per hub, yes? You need to allow for 500ma for each panel. Also go into your Windows device manager and ensure power management is OFF for each USB hub. Finally, yes, use a 2.0 port if you can. Saitek stuff doesn’t often like 3.0 ports. Finally, this may help: http://www.ontheglideslope.net/2016/04/22/power-to-the-hub/

    0

    N15JG On PilotEdge

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.