The Rift Is Dialed In

OTG Blog Forums Virtual Reality The Rift Is Dialed In

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #3382

    Basement Fly Guy
    • Posts: 228

    At least for now. This is cross-posted from the main blog.

    ***

    After continued testing and trial, I’ve found settings that work very well for me in the Oculus Rift, with smooth movement and no judders. Sitting at Albert Whitted near Tampa I was getting 90-100 FPS before activating VR and 45+ with it at the default KSPG airport, and 60-70/45 with the custom KSPG (which is much more taxing). Weather was set to real world, with some clouds in the area. The 45 FPS held as I flew around the Tampa area, held when I turned on WorldTraffic 3.0, and held when I went from non-HDR to HDR lighting effects. I did have more pauses and stutters after moving to HDR, though, so I will fly with it at night only. Without WT3 I don’t know that I would have had these, and I also realized my custom KTPA was loading on top of the Tampa scenery package KTPA, so the sim was managing two large airports on top of each other. But the flying was great, and I’ll be using these settings going forward. And it was really great to experience a big airport with traffic moving around in VR.

    After reading a number of posts online at the Facebook Virtual Aviation Group, I decided to run without the Oculus app running (set the Occulus app to “Run As Administrator” and it will stop loading whenever the Rift is active) and without OTT or the Oculus Debug too, and instead only use SteamVR. I figure the fewer the software layers involved the better. Here are my settings (and remember I’m running an i7 6700 clocked to about 4.6 and a 980TI also overclocked just a bit):

    • In SteamVR:
      • Developer Tab: Supersampling set to 2.0 and Advanced Supersampling Filtering ticked ON (I picked 2.0 on a lark, and don’t know how high I can go with this yet)
      • Performance Tab: Allow asynchronous reprojection and Allow interleaved reprojection ticked ON (this was important – when I turned these off I had judders galore)
    • In the X-Plane Graphics Tab:
      • Main monitor set to 1280×720 – I figured by downscaling the main monitor I’m saving processing power for the VR headset (this may or may not be the case, but I’m happy with the results)
      • Visual Effects set to middle setting (one below HDR)
      • Texture Quality set to Maximum (one below highest setting)
      • Antialiasing off (I didn’t miss it with the supersampling, although adding AA didn’t hit frames that much; when I turned on HDR visual effects I set AA to off)
      • World Objects set to High (one below max)
      • Reflection Detail at lowest setting
      • Draw Shadows On Scenery set to off
    • In the 3jFPS plugin (a must-have, in my opinion) I ran the wizard and set it to keep frames at 50, which I figure will keep me at or above 45 FPS most of the time. I still had a world full of objects even with the plugin running.

    Ironically, those settings are quite close to what I ran with in non-VR. But the important thing was that I was getting 100 FPS sitting at the default Albert Whitted, and I do believe setting the main monitor to 720p had something to do with that. The only downside was that it moved all my icons around on my desktop! Next step is to try the VR on PilotEdge …

    N15JG On PilotEdge

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.