X-Plane Plane Maker Not Working

Home Forums Software X-Plane Plane Maker Not Working


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #3186
    Nick Pickett

    Looking for help elsewhere as X-plane forums have not responded or helped.  Fan of this site and those on here so decided to try here.  I cannot get Plane Maker to work on my computer.  It loads up and when I go to open an aircraft it just sits there for eternity with the folders screen up.

    I have tried resetting the preferences folder, ran the program in other compatibility modes (Windows 8, 7, and vista) with no success.  I’m trying to run it on my surface pro 4, windows 10 so not sure if that is the problem.  Not super fast processing (i5-6300), 4 GB RAM, but I wouldn’t think that would affect this program (have an intermediate computer knowledge level).

    Didn’t know if anyone else had this problem and got it fixed or had any other ideas?  Thanks.

    Basement Fly Guy

    PlaneMaker strikes me as a very lightweight program from a processing / power standpoint. I don’t know that preferences deletion would help much (though it would not hurt). My first step would probably be to run the X-Plane updater program. It should download or replace anything that’s missing or out of date. A second step might be to move PlaneMaker to a different folder, then run the updater and see if XP re-downloads it. That fresh install may work. Third step for me would be to try loading a different aircraft in PlaneMaker and see if that makes a difference. If none of that works, XP support tends to be pretty helpful if you contact them.

    N15JG On PilotEdge

    Nick Pickett

    Thanks for the advice but it is still not working.  I did get it to load one time and was able to edit the call sign for my Cessna (all I’m really trying to do).  I closed it to see if it changed it in X-plane and it did but I should have changed the call sign for my baron while I was in there.  I don’t know what else to do.  I have tried everything I can think of (which is not much).  It’s frustrating that sometimes it gets stuck when I click open and sometimes it gets stuck when I click the extra aircraft folder.  Waiting for suggestions if anyone has any.

    Richard Wolff

    Maybe (ie, untried)  … just edit “tailnum” in the acf file.


    Not sure if this has been sorted, and I imagine you’ve likely already tried (since you mention compatibility mode), but have you tried running as admin?  Odd situation – hope you get (got) it fixed.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.