The Problem Seems To Be The Rift

If you’ve tuned in or watched the last few YouTube flights I’ve posted, I’ve been having problems with GPU usage in the sim. Things are great for the first 20 or 30 minutes, at which point my GPU usage goes to 100%, frames plummet, and the sim crashes (often crashing the entire PC). Nothing seems to fix the issue.

The past few flights have been in VR. I have found the Oculus software since the Rift S quite buggy, and as an experiment yesterday I disconnected the Rift S and went back to my three-screen physical cockpit setup. I ran the sim for several hours, with clouds and over the ORBX Washington scenery, with absolutely no problems. Frames were down in the 20s at some points, but overall they held in the 30s (with the benefit of VMI Twick to limit objects some), and most important, I had no crashes and the GPU never really went above 60% utilization. I don’t believe the issue is the increased hardware requirements of the Rift S compared to the Rift, as it will run just great for a while before cratering. It must be a software issue. So I’ll be abandoning the VR for a while, at least until Oculus gets their software hammered out.

2 thoughts on “The Problem Seems To Be The Rift

Leave a Reply

Your email address will not be published.

The following GDPR rules must be read and accepted:
This form collects your name, email and content so that we can keep track of the comments placed on the website. For more info check our privacy policy where you will get more info on where, how and why we store your data.